Yocto Development Environment

From Variscite Wiki
Setting A Development Environment

1 Supported Linux Distributions

The full list of the Linux distributions that are suitable for latest Yocto Project development is referenced here.

We recommend using Ubuntu 64-bit on a powerful physical PC (though using a virtual machine is also possible):
For Yocto Krogoth and below, use Ubuntu 14.04 64-bit.
For Yocto Morty use either Ubuntu 14.04 or 16.04 64-bit.
For Yocto Pyro, Rocko, Sumo, Thud and Warrior use Ubuntu 16.04 64-bit.
For Yocto Zeus and above use Ubuntu 18.04 64-bit.

2 Installing Ubuntu 14.04 64-bit in VMWare Player (for Yocto Morty and below)

There are many tutorials on the web. For example:

3 Installing Ubuntu 16.04 64-bit in VMWare Player (for Yocto Morty and above)

There are many tutorials on the web. For example:


4 VMware player recommended settings

  • Set the number of CPUs to the maximum possible.
  • Set the memory size to at least 8GB.
  • Set the disk size to be at least 200GB. 300GB is better.
  • Use Bridge for networking.
  • Install the VMWare tools.
  • If you have an extra hard drive you can use it as a physical partition and set you home directory to it.
  • Update Ubuntu right after the first login.